Simon XTi - "Radio Not Responding" Trouble

There are several possible reasons for why the radio is not responding:

  • Power is down and the backup battery is drained. Press the gears button on the bottom right of the screen. Scroll down to System programming, press "Enter" and punch in installer code (4321) and then go to Interactive Services, and press "Module Status" to verify the voltage. If it is less than 6.2 Volts then you need to make sure the battery is connected and let it charge for 24 hours. Also on this screen, you can check to see how many bars of signal strength your panel is receiving. If you are only receiving one bar, then you should contact Brinks for additional troubleshooting.
  • Verify the connections on the AC Transformer (it should be connected to terminals 4 and 5, underneath the battery in the panel) and make sure it is plugged into the wall. 
  • The radio may need to be powered down and then back up. Do this by unplugging the transformer and backup battery, then plug the battery back in, followed by the transformer. Then wait 10 minutes and press the gears button, and then press "Listen" followed immediately by "Clear", and that will delete all old messages.
  • The radio has been tampered with, destroyed, disconnected or has otherwise malfunctioned. Check the LEDS on the unit.
  • Lastly, make sure the antenna is connected to the radio. 
Was this article helpful?
0 out of 2 found this helpful

Comments

0 comments

Please sign in to leave a comment.