I have followed the setup instructions, and am getting unexpected results from my keypad.

1.  The Key Backlight stays on all the time as it should, but the display backlight goes out 15 seconds after connecting AC power, and never comes back on, even when changing or requesting status.  The message indicator acts as it should with AC power, staying on.

2.  The Ready light is sometimes on, and sometimes off, like it may be responding to the motion sensor, which is properly set as Zone type 10.

I have tried to reset the unit by  removing and replacing the batteries and have removed and reconnected AC power.  I have set my Lynx Plus alarm to keep the backlight on in case it is commanding the remote backlight off, but nothing seems to help.

0

Comments

1 comment
  • Morris,

    This sounds like it is a power related issue, here are a couple different things to check and try. First I would recommend checking the connection on the keypad itself, make sure that the AC power cord is not loose and that you have a nice snug connection. Alot of times if there is a bad connection then by moving the connector from side to side you will see the screen light up and then turn off.

    I would recommend trying to get the power cable replaced first if you have a warranty on it, otherwise you may have to purchase a new one.  We sell the desk mount and power supply together and you can find it on our website if you click here.  If that does not fix it then you may have a defective connection on the keypad itself and it would need to be replaced. Those are available on our website as well and can be found if you click here.

    0
    Comment actions Permalink

Please sign in to leave a comment.